Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I search for something on wikipedia with google and try to click through to one of the articles, IE8 prompts me to download the page as it doesn't understand the mime-type.

This has not always been the case. It started about 2 weeks ago. I had not changed any settings or installed any software. At the time I checked my windows restore points and there were none within a few weeks of the symptom occuring.

Does anyone have any possible explanation for such behaviour?

32bit Vista SP2, IE8

UPDATE

OK. So this only happens when I try to click through to Wikipedia from some other site. If I type wikipedia.org into my address bar and hit return it shows the page no problem.

share|improve this question
    
Does this happen with all pages or only certain types? –  Joshua Nurczyk Jul 15 '09 at 16:28
add comment

2 Answers 2

I try guessing:
If you go to "Tools -> Internet Options -> Programs -> Manage Add-ons" you can see (using the "Show" drop-down box) which add-ons are currently loaded. Maybe IE does not load the appropriate add-on when needed. Have a look, if you can force it to do so.

share|improve this answer
    
IE shouldn't need an add-on to display an HTML page...? –  Greg B Jul 17 '09 at 12:23
    
You are talking about HTML as mime type? Well, I didn't get that from your question. Sorry for the misunderstanding. –  John Smithers Jul 17 '09 at 12:44
add comment

First, have you tried to reproduce the issue by running Internet Explorer 8 in safe mode? I believe there is a shortcut in your start menu. If the problem doesn't occur in safe mode, then start to eliminate add-ons... (If you can't find the safe-mode option just skip to the add-ons section)

Add-Ons

You can modify add-ons by:

  1. Use alt key to bring up the drop down menu.
  2. Click on Tools -> Manage Add-Ons -> Enable / Disable Add ons.

You should then be looking at a page like the following.

Manage Add-Ons screen shot

From there, disable / remove any odd, unusual or unwanted add ons. If the problem continues to persist, I'd disable all add-ons to see if it resolves the actual problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.