Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am attempting to open an SVG file with Internet Explorer 9 (32-bit). When doing so, I am prompted with the standard Open, Save, Save As dialog.

This happens when dropping an SVG file onto IE or opening it directly from Explorer. However, it displays properly when the full, local filepath is entered straight into the address bar.

Open, Save, Save As dialog, 32-bit IE9

A similar question was recently asked on Technet. The (unsatisfactory) answer suggests it is add-on related. And indeed, Internet Explorer (No Add-Ons) and Internet Explorer (64-bit) behave as expected. But neither the reset utility nor manually disabling every single add-on has helped the 32-bit version.

I appreciate any suggestions or insight into this.

share|improve this question
I guess it's a security setting relating to opening local files, though I may be mistaken. – user3463 Dec 14 '11 at 18:55
@Randolph, that was my initial assumption as well. Turns out some (old) SVG software had reassigned the CLSID for the image/svg+xml MIME type. Assigning the Browse In Place CLSID (mirroring text/html, etc) solves this. Details in my answer, below. – zourtney Dec 14 '11 at 20:10
Good find! Don't forget to accept your answer. – user3463 Dec 16 '11 at 7:23
up vote 1 down vote accepted

This issue can be fixed by assigning the Browse In Place CLSID to the offending content type. This will not affect Explorer's "Open With" association. The following *.reg script will alter type image/svg+xml.

Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\MIME\Database\Content Type\image/svg+xml]

Credit: Cheeso's application/json answer.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .