Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm sorry to say there are several things I liked better in Snow Leopard. Sorting files in Finder is one of those things.

If I "Arrange By" -> "None" it does not group items and it looks like 10.6. I like this. I can still click on the bar to sort by name, etc., and it looks fine and does not group:

enter image description here

However, if I select "Arrange By" and choose another option, the folder starts looking different (column headers) and it starts grouping things:

enter image description here

  1. I don't want them grouped.
  2. I want to use the old keyboard shortcuts, I think they were alt+1 - alt+6 to change the sort order. Also, pressing the keyboard shortcut again would toggle the sort order from ascending to descending.

How can I make my life better on Lion? Applescript would be an acceptable solution, but maybe editing the default plist file could also work or unlock some hidden option.

share|improve this question
3  
+1 this behaviour is insane. – Daniel Beck Dec 15 '11 at 6:08
1  
@DanielBeck - haha, thanks for the upvote. Losing this functionality reminded me of transitioning from XP to Vista and no longer being able to easily do a view by list with alt-v-l or sort by date with alt-o-d - I really hope there is a workaround. – cwd Dec 15 '11 at 8:08
    
The previous keyboard shortcuts were repurposed. Ctrl-Cmd-N sorted by the column, instead of arranging. – Daniel Beck Dec 15 '11 at 8:11
    
I really hate the grouping and so glad to see a solution. – netrox Jul 12 '14 at 16:46
up vote 7 down vote accepted

You need to press Ctrl-Opt-Cmd-Number instead of Ctrl-Cmd-Number.

To get the sorting (instead of arranging) menu items, hold down Option. The implemented the Sort by/Arange by submenu somewhat oddly though, so pressing Option while it's already visible won't change the menu items.


enter image description here

share|improve this answer
    
Awesome. I wondered why I didn't have the "Sort by" in the menu. Yes, holding option was the trick! Thanks! – cwd Dec 15 '11 at 19:47
2  
Any way to press it more than once and have it toggle ascending / descending? – cwd Dec 15 '11 at 19:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .