Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows 7.

The "Devices and Printers" panel shows I have no items even though they are accessable in the control panel.

Other web sites have suggested the problem lies in the bluetooth settings in the system. I have tried disabling bluetooth and setting it on automatic without success.

Nothing seems to work, any ideas?

share|improve this question
    
Same exact problem here, Bluetooth is what "everyone* recommends, but it makes no difference. sfc scan comes up fine too. Boo. :-( –  Brian Knoblauch Jun 21 '13 at 16:01
    
Same issue (and its 2015). Although I was able to get to the printers by printmanagement.msc. It at least allowed me to add/remove printers. However, still can't change the default printer. (and yes, I tried restarting Bluetooth and print spooler services and sfc/scannow thing. None worked). Great job @Nadela keeping up with Windwos traditions. –  FractalSpace May 31 at 16:18

3 Answers 3

What does the 'Control Panel/Administrative Tools/Print Management' show?

Check your event logs for any errors relating to the Print Subsystem or Spooler service failing as that will give you an indication why. (Printers vanishing can be a regular symptom of the Print Spooler crashing/not running)

share|improve this answer
1  
The 'Control Panel/Administrative Tools/Print Management' shows all the printers and devices. But I could not find any errors relating to the Print Subsystem or Spooler service failing in the events log. If the items are all in the 'Control Panel/Administrative Tools/Print Management' why are they not showing in the devices and printers panel? Is there something I can do to transfer them over? –  Keith Stevenson Dec 16 '11 at 10:05
    
They are not in 2 different locations, the Print Management window shows everything associated with the underlying print services, drivers installed etc. Have you installed all Updates, Service packs and verified your machine is Virus and Spyware free? Next step would be running 'sfc /scannow' to verify Windows is healthy. –  HaydnWVN Dec 16 '11 at 13:05
1  
Thank you again for your advice, I have now run the sfc/scannow programme and it reported "Windows Resource Protection did not find any integrety violations" which is I suppose good news, but the problem persists, –  Keith Stevenson Dec 21 '11 at 8:26

I finally found a solution to this on my computer. I had another user log into my machine and it worked fine for them. Therefore it was just a per user failure. I logged in as administrator and blew away my account (via the advanced settings menu). There must have been something broken in my account as when I logged back in and my account was rebuilt it started working fine.

Note that doing so destroys all saved documents, libraries, browser shortcuts, user customizations, etc. If you have anything at all on your machine that you love, you need to back it up first!

As a side note, in the account settings menu where it lists profile size, it just had a "?" for my account. I do a lot with accounts and have never seen a question mark for size before!

share|improve this answer
1  
Another option is to rename your profile. What this does is builds a new profile while still allowing your old profile to be accessed. –  Kruug Jun 21 '13 at 20:06

On my system I found that I had the same problem while trying to clean up a new Windows 7 installation; no comments on Win 10.

  1. Right click Start > Devices and Printers. With this open you can see what's going on. It helps to have a removable device such a camera plugged in since it will be very visible very quickly.

  2. Next start Task Manager and look for two entries, BTStackServer.exe, and BTTray.exe. These should be loaded and running.

  3. Left click Start > Run > then type services.msc. The alternative is to right click on Start > Administrative Tools > Services. Your system may or may not have the latter visible. The former will always work unless your system is seriously buggered up.

  4. Look for two entries, Bluetooth Service and Bluetooth Support Service. The actual service is called btwins. Make certain that both have their status as Started and that both are set to start Automatic. If not, make those changes and if necessary click on select each service and select Start.

All things being equal, the window should fill almost instantly. Although there could be registry issues, be very wary unless you have experience with registry tweaking.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.