Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a MacBook Pro. I've set up the VPN using settings that were on my Windows laptop.

I can connect to the VPN and see everything on the office network (ping IP addresses, view intranet sites by IP address, among others). However, nothing is accessible on the Internet. I can't even ping

I've tried sending all traffic over VPN and turning that option off. Nothing seems to work.

Does anybody have an answer for this?


I'm using the default VPN client on OS X, PPTP.

share|improve this question
What VPN client are you using? Does the Windows laptop still allow you to get to when connect to the VPN? – Paul Dec 15 '11 at 23:21
Good question -- and if you're using the native VPN client built into OS X, what sort of VPN connection is it? L2TP over IPSec, PPTP, Cisco IPSec? – Doug Harris Dec 15 '11 at 23:53
Sorry- using the default VPN client in OS X, PPTP Have updated question – alex Dec 16 '11 at 11:10
I have this issue too. An easy fix is usually to create another VPN adapter in the system preferences. Try that. – Thelolguy 10 hours ago

2 Answers 2

Your VPN server has not enabled split tunnelling, therefore all traffic is redirected through the tunnel. When the VPN client connects, it changes the default route of your machine.

The solution is to remove the rogue default route and add back your original default gateway.

To discover the IP address of your default gateway:

  • disconnect from the VPN
  • go to System Preferences -> select your network connection -> click Advanced -> TCP/IP
  • look under 'Router'

Assuming that:

  • you use your VPN tunnel to access the subnet
  • your default gateway is

then you must:

  • first connect to the VPN
  • then use the route command to change the default gateway back to the original value
  • and add a static route to the VPN subnet

The last two steps translate into these commands:

sudo route -nv add -net 192.168.108 -interface utun0
sudo route change default

If you can ping public IPs, but you can't resolve hostnames, it means the VPN client also replaced your DNS servers.

Go to System Preferences -> select the VPN connection -> click Advanced -> manually enter the IPs of your DNS servers there, to override the ones sent by the VPN server.

share|improve this answer

Try going to google via IP address -- try

If that works, I'll bet that your VPN blocks whichever name servers you were using without the VPN connection. On windows it probably set you up to use company-managed DNS servers.

If this is the problem, possible solutions:

  • Manually configure your name servers to use the company-managed DNS servers
  • Try different publicly accessible name servers (e.g opendns or google's public DNS or find others using namebench)
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.