Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have made an XPS document in Microsoft Word (Print --> print to XPS Writer). On Windows 7 (64 bit) machine I can open this file in XPSViewer or IE and send it to an actual printer, where the XPS document is successfully printed. All testing so far has been done on Networked printers.

On my windows XP (32 bit) machine, I can create an XPS document with Microsoft Word, but my attempts to print the XPS document to an actual printer are unsuccessful. This machine indicates that the job was successfully sent to the printer, but the printer does not print the document, and printer logs indicate that the job was not received. I am attempting to print to the exact same printers from both the XP and the Win7 machine. Attempting to print non XPS documents still works fine on the XP machine.

What could be missing from the XP machine that would cause this kind of behavior? I have .Net 4.0 framework installed.

share|improve this question
    
Is the XP computer fully patched to SP3 and including optional Windows Updates? Is this a net printer ? –  harrymc Jan 4 '12 at 21:10
    
Yup. All patches are applied and XP is at SP3. This is a network printer (local, LAN). –  ford Jan 6 '12 at 17:29
    
Can the XP machine print anything else to the printer? –  shufler Jan 11 '12 at 0:51
    
Other things can print. MS Word 2007, if not printing an XPS document, can print successfully, for example –  ford Jan 11 '12 at 1:07
add comment

4 Answers

Potentially a driver issue on your XP setup

Why not try SumatraPDF 1.9 to read the XPS (Portable version is a single file, no install) then try printing from its window if that fails it can save as PDF open that then try print again that will prove if its the app (xps viewer) or printdriver/spooler rejecting some xps string

If it is the latest driver try modifying some advanced settings such as spooling raw etc.

share|improve this answer
    
I tried SumatraPDF and it was able to load the XPS file fine, but am unable use SumatraPDF to save my XPS file as PDF ( forums.fofou.org/sumatrapdf/topic?id=2344326 ) –  ford Dec 16 '11 at 16:39
1  
Other than that issue, SumatraPDF is able to print the XPS document –  ford Dec 16 '11 at 16:49
add comment

SumatraPDF can send files to a printer directly via the CLI.

Prints a PDF file on a default printer

-print-to-default $file.pdf

Prints a PDF on a given printer

-print-to $printer_name $file.pdf  

Opens a PDF file and shows a print dialog to select printer and printing options

-print-dialog $file.pdf  

When -print-to-default or -print-to is used, will exit after printing

-exit-on-print  

So try:

drive:\path\SumatraPDF.exe -print-to-default -exit-on-print "drive:\path\my test file.xps"

or

drive:\path\SumatraPDF.exe -print-dialog "drive:\path\my test file.xps"

share|improve this answer
add comment

Based on this post, try to disable printer spooling.

This is done in the printer's Properties, Advanced tab, check "Print directly to printer".

share|improve this answer
    
The 'Advanced' tab is disabled. Would this be due to a lack of permissions? –  ford Jan 11 '12 at 0:58
    
Yes, if this is a shared network printer. –  harrymc Jan 11 '12 at 9:02
add comment

I believe their are internal MS issues with their XPS option and 64bit OS machines. MS OneNote has a great "Send to OneNote" print option which uses XPS drivers I believe... but not if it was a 64bit OS, at least for OneNote 2007 versions. A Microsoft OneNote team engineer, on his own time, wrote up a "fix around" for Sending to OneNote on x64 machines which involved an XPS driver of his own making that he posted for download. It wasn't even an official MS driver solution. They might have fixed it for the OneNote 2010 version, or not. But 64 bit OS XPS options were problematic from Microsoft having not addressed it properly. You may have to search MS to see if they have any quick fix drivers for the specific XPS problem. I got lucky searching their MS OneNote website.

share|improve this answer
    
Thanks for the help, but in my situation, the 64 bit OS is doing what I need to, but 32 bit XP is not working. –  ford Jan 11 '12 at 1:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.