Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Windows 7 64-bit and recently installed VirtualBox on which I installed Ubuntu 11.10 64-bit guest OS.

Everything runs smoothly until I found that I am not able to shutdown or reboot the virtual machine in a normal way (from within the guest OS). Whenever I do so, it just goes back to the login screen.

I have to use the VirtualBox's menu to force a shutdown. Has anyone experienced this before?

Thanks in advance!

share|improve this question

migrated from Dec 16 '11 at 8:30

This question came from our site for professional and enthusiast programmers.

Can you clarify "The normal way"?

Have you tried running:

sudo reboot


sudo init 0

from the terminal window within the guest OS? If so could you post what happens?

share|improve this answer
shutdown -P now, shutdown -h now, poweroff, halt -p, ... – tyblu Dec 16 '11 at 18:02
@tyblu I assume there is a sudo prepended for all these commands. But there is a bug that has been confirmed for 11.10. – Karlson Dec 16 '11 at 18:15
Hi Karlson, by normal way I mean clicking on the "Gear button" on the top right corner and select "Shutdown" and then either "Shutdown" or "Restart" brings me to the login screen. Yes I have tried "sudo reboot", same problem. – airfang Dec 20 '11 at 7:28
up vote 0 down vote accepted

The problem went away with later versions of virtualbox.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.