Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't use Oracle VirtualBox remote display feature.

I have host OS of Fedora 15 PAE. This OS is running Virtual Box with the same guest OS (Fedora 15). The network driver of virtual box is in bridge mode. Host OS is running Gnome 3, so as guest OS.

In this situation, I can see both machines separately from my windows 7 machine. I can SSH to them, I can VNC to them and I can RDP to them. All these features work with installed fedora software (ssh daemon, vncserver, x11vnc, xrdp etc).

But if I understand correctly, VirtualBox has it's own screen sharing for RDP protocol. Unfortunately, I can't use this feature.

I have set up remote display in Settings-Display-Remote Display tab of VirtualBox. I have set the port to 3390 not to interfere with already running rdp. I have set View-Enable Remote Display to "on" in the virtualbox window's menu.

Also I have opened port 3390 on both machines in firewall.

So now, how to connect to this display correctly? Should I connect to host's IP or to guest's? I think that it should be host's. But I can't connect to it with windows' rdp client...

share|improve this question
    
I can't promise how fast but I have done this before some time ago... very handy... let me try and find it :) –  OG Chuck Low Dec 16 '11 at 17:56
    
Do you have Terminal Server up on the host box? –  OG Chuck Low Dec 16 '11 at 18:03
    
What do you mean by "Terminal Server"? I can access host with multiple ways. –  Dims Dec 17 '11 at 8:26
    
sorry it was a dumb question.. that you could rdp the box in the first place answered it :( –  OG Chuck Low Dec 19 '11 at 16:12
add comment

2 Answers 2

You need to connect to the host rather than the guest. I would split the problem into two and suggest firstly you try and connect on your host to the guest with something like

rdesktop localhost 3390

and see if you get a connection.

If that works, then go to your windows machine and connect with "Remote Desktop Connection" specifying the hostname and the connection separated by a colon(:)

so something like

myserver:3390

If this still doesn't work, what sort of errors are you getting? Is the connection rejected or does it time out. Can you turn on logging on your firewall, or turn off the firewall altogether briefly to check its not a firewall problem.

share|improve this answer
add comment

First you need to make sure you have the VirtualBox Extension Pack installed. Get it from here: https://www.virtualbox.org/wiki/Downloads

Once this is installed, enable the virtual display for your VM. Now you need to connect with a rdp viewer to the host's ip address.

But if you are connecting to the local host then according to the virtualbox help documentation:

When connecting to localhost in order to test the connection, the addresses localhost and 127.0.0.1 might not work using mstsc.exe. Instead, the address 127.0.0.2[:3389] has to be used.

share|improve this answer
1  
That's quite silly that the whole thing can be configured w/o the extention, but doesn't work and doesn't even indicate that... –  sstn Sep 5 '13 at 12:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.