Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the latest dev version of Google Chrome (17.0.963.6 dev) on OS X Lion (because I heard the latest version works better with Lion).

I've cleared my cache and history, but when I search from the address bar it is very slow - perhaps 5 - 6 seconds before it will pull up a result. I've unchecked the boxes for the extra features in the preference pane, but that doesn't seem to help:

enter image description here

When I search from the search box in Safari it is almost instantaneous, so I know it's not my internet connection. How should I troubleshoot this?

share|improve this question
    
I have this issue too and would like to know something about it. –  Nanda Dec 16 '11 at 17:14
    
@KishorNanda - I used the wrench icon » about chrome and it said there was a slightly newer (point) version. I downloaded it via google.com/chrome/intl/en/eula_dev.html?dl=mac and it seems to be working a little better - at least for the moment. –  cwd Dec 16 '11 at 17:26
2  
Isn't this why they are called Dev versions, a bit buggy? –  Moab Dec 16 '11 at 19:55
2  
@Moab - yes but unfortunately the "stable" version for lion is actually not all that stable. –  cwd Dec 16 '11 at 20:01
    
Does it also happen with a new user account? –  Daniel Beck Dec 17 '11 at 11:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.