Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently switched over from BT to O2 for broadband. After setting everything up, my laptop and smart phone can access the internet via Network cables and Wireless, also my Roku music server can stream music.

The big mystery is an old Dell laptop Latitude PP04S, Intel Pentium M Processor 1200 MHz running Windows XP Professional Service Pack 3 (which used to connect to the old BT router). It can see and connect to the WiFi signal, but can't access the internet.

Does anyone know what's going on or what I can do to fix it?

share|improve this question
Do you get a local IP? have you tried to ping anything (local/remote)? Did this laptop previously have static IP? Are there any errors you see when you connect? Please provide more details about the router and any errors you see. – Kyle Dec 16 '11 at 18:46
Hi kyle,Thanks for answering my post, how do i know if i get a local IP? not sure if it was a static Ip, i am currently accessing the internet on my other Dell Laptop, how can I check its settings? – Alana Dec 16 '11 at 18:53
On the laptop that is having issues go to start>run type in "cmd" (no quotes) then type in "ipconifg" also no quotes. Post the IP address here it should look like: or something similar. – Kyle Dec 16 '11 at 19:17
To add to the above maybe a DNS issue as I recall an old BT service where I had to manually set the DNS. On the cmd prompt try "ping" – Wudang Dec 16 '11 at 20:18

1 Answer 1

My guess would be that the laptop previously required a static IP address or manual configuration, and now your network details have changed. Try setting the Internet Protocol (TCP/IP) Properties to Obtain an IP address automatically and Obtain DNS server address automatically.


To get to these settings, go to:

  • Control Panel > Network Connections
  • Right-click on the wireless adapter and click Properties
  • Double-click on Internet Protocol (TCP/IP)
share|improve this answer
Thanks to everyone, i will check these options out and get back to you all may be a couple of hours. – Alana Dec 16 '11 at 21:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.