Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I right click on "Computer" and click "Manage" I get the message service cannot accept control messages at this time. What is the cause of this and how do I correct it?

I am running windows 7 Pro x64

share|improve this question
Have you tried rebooting? Logging out and in again? A virus scan (known to cause this, at least according to a quick google on the error message)? Did this ever work right? If so, have you tried a System Restore to a point back in time when it WAS working? – Ƭᴇcʜιᴇ007 Dec 16 '11 at 20:50
I was hoping to get to the cause of the issue, rebooting resolved it for now. – Icode4food Dec 16 '11 at 21:01
up vote 9 down vote accepted

Each windows service contains a message pump, e.g. there is a loop that waits for messages from Windows or other sources, dispatches them and acts upon them.

When a service gets a "stop" message, for example, it is considered in a "stopping" state by a service manager. While in a "stop-pending" state, it cannot accept conflicting commands, like "start". When it happens, you get the message you cited.

When a message hangs in its message processing code, or it just takes a long time to process a command, you can get this problem. You can wait a minute or two hoping that this is just a temporary problem that will be resolved by itself. In my experience, it rarely does.

Now, when you click "Manage" from "Computer" menu, Microsoft Management Console opens, possibly after an elevation to Administrator. There are a number of services involved, I don't know which one is misbehaving.

After a reboot, open an Event viewer and look in the System log. It should have a message from Service Control Manager about which service had this problem. If you get this problem again, kill the offending service from task manager, and restart it from the command line, e.g. net start servicename

share|improve this answer
What a strange error message. – surfasb Dec 18 '11 at 19:38

This issue is caused by the Application Information service not responding to requests to elevate applications to Administrator, causing the error message.

  1. Log in as the local administrator account.
  2. Open Services.msc, and keep it minimized (the following steps will prevent you from running services.msc to start the service after it has been killed so services.msc will need to be open beforehand!)
  3. Run Process Explorer as Administrator
  4. Kill the svchost.exe netsvcs process.
  5. Then start the Application Information service from Services.

Check all automatic services as a few may have stopped and start them again.

This should resolve the issue.

This is particularly helpful on critical production servers which can't be rebooted as that could cause disruption to service, but can also be used on desktops if you don't wish to reboot.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.