Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a package named libqt4-designer and another package named libqt4-47-designer. When I do aptitude remove libqt4-designer, Aptitude wants to remove kdesudo and many other applications. How can I replace the libqt4-designer dependency with libqt4-47-designer?

Thanks

share|improve this question
    
Why do you have to remove it? What release of Ubuntu are you using? where did you get libqt4-47-designer from? What repository? –  Zoredache Dec 16 '11 at 21:46
    
It's launchpad.net/~forumnokia/+archive/fn-ppa . This is the only ppa I know with the most-latest qt-sources. I'm using Linux Mint 9 = Ubuntu 10.04 and I want to remove it to have the latest libs. –  user925405 Dec 16 '11 at 21:57
add comment

1 Answer

If the libqt4-47-designer includes the Provides: libqt4-designer it its description, then all you should have to do is install it. If it doesn't, then you may have leave libqt4-designer.

I suppose you could build a dummy package with equivs to replace libqt4-designer, but you had better be certain that libqt4-47-designer will work as a replacement before you try doing this, you can make a serious mess.

If you look at the libqt4-47-designer package description, it does seem to conflict, replace, or break libqt4-designer. Since this is the case, I there should be no reason to remove it, if you did remove it, this package will almost certainly not provided the functionality needed, and you will break your system if you remove it.

Package: libqt4-47-designer
Source: qt4-47-x11
Priority: optional
Section: libs
Installed-Size: 9076
Maintainer: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>
Architecture: i386
Version: 4:4.7.2-0fn~lucid0
Replaces: libqt4-47-gui (<< 4.4.0~beta1-1)
Depends: libc6 (>= 2.3.6-6~), libfontconfig1 (>= 2.8.0), libgcc1 (>= 1:4.1.1), libqt4-47-script (= 4:4.7.2-0fn~lucid0), libqt4-47-xml (= 4:4.7.2-0fn~lucid0), libqtcore4-47 (= 4:4.7.2-0fn~lucid0), libqtgui4-47 (= 4:4.7.2-0fn~lucid0), libstdc++6 (>= 4.1.1)
Breaks: libqt4-47-gui (<< 4.4.0~beta1-1)
share|improve this answer
    
It's launchpad.net/~forumnokia/+archive/fn-ppa . This is the only ppa I know with the most-latest qt-sources. –  user925405 Dec 16 '11 at 21:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.