Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've moved /home to a separate partition, this involved creating and mounting the new partition, copying the old home directory over to the newly mounted one, editing fstab to mount the new partition as /home on boot. This has worked great for my admmin account but not for the other user accounts.

I copied like so

http://embraceubuntu.com/2006/01/29/move-home-to-its-own-partition/

mv /home /old_home

mv /new_home /home

I then made sure that ls -l was the same for home as old_home

I think it may be to do with the edits to /etc/fstab only mounting the partition for the user I edited it as

edits below:

/dev/sdb1      /home            ext4    nodev,nosuid      0       2,

My guess would be the options nodev, nosuid but without knowing what to change this to im reluctant to make further edits.

Any suggestions ?

share|improve this question

migrated from stackoverflow.com Dec 16 '11 at 22:52

This question came from our site for professional and enthusiast programmers.

    
In what way does it not work for the other accounts? –  Chris Dodd Dec 16 '11 at 21:30
1  
How have you copied /home? And what do you mean by "doesn't work for other users"? (and btw this should go to serverfault) –  fge Dec 16 '11 at 21:32
    
how is it a server fault ? Im talking about a netbook, and a partition of an SSD ? –  Luke Dec 16 '11 at 21:34
    
@ChrisDodd When logging in as a user that doesn't have admin priveleges the menu doesn't populate, you can't browse to /home –  Luke Dec 16 '11 at 21:37
1  
@fge it should go to unix. –  Kevin Dec 16 '11 at 21:44
show 3 more comments

1 Answer 1

up vote 0 down vote accepted

The cp command doesn't copy hidden files (i.e. files that begin with .) so this will cause a big issue as all of the .bashrc and any other settings (e.g. .vimrc, .screenrc, .dircolors, etc) will be lost.

You could try doing the following from the home directory:

tar cpf - . | (cd /new_home; tar xf -)

which would transfer all file including the hidden ones and retain all permissions of the files and folders.

share|improve this answer
    
I'm sorry I actually did $cd /home/ $find . -depth -print0 | cpio --null --sparse -pvd /mnt/newhome/ I couldn't ind the page i referenced so went back through the terminal history and must have identified the wrong line, having moved to my PC i browsed back to the guide here –  Luke Dec 16 '11 at 23:07
    
its working ok for my account but not for the existing user accounts, I've deleted these (there was only 2) and recreated a new user and the problems appear to be the same –  Luke Dec 16 '11 at 23:59
    
I formatted the HDD and used the above bash commands when copying the directory to the new partition. so far its been ok. Thanks –  Luke Dec 18 '11 at 1:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.