Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Where I work, I had a user that installed Google Chrome on his Windows 7 SP1 64-bit system under his account (domain environment, he is local administrator) accidentally when installing Google Earth.

The user did not check the "Use Chrome as default" checkbox and thus local .htm/.html files were by default opening in Chrome. Our ERP software is based on ActiveX and therefore will not work in Chrome. So I uninstalled it.

Now, whenever local .htm/.html files are opened, IE 8 launches, but instead of rendering the page, the source code of the page is displayed - as though it's not recognizing that it is an .html file but a text file.

Remote .htm/.html files open OK, i.e. when IE 8 is opened and an address is typed. It is only when a local .htm/.html is opened that IE will not recognize it as HTML.

I have since reinstalled Chrome, but did not set it as the default browser. However, the behavior persists.

Any ideas?

share|improve this question
1  
Is there a difference in the address when you open the files locally vs remotely? –  iglvzx Dec 16 '11 at 23:17
1  
What is the default program set to for .htm or .html files? This can be found in the Default Programs list. –  Dean Perry Dec 16 '11 at 23:41
    
Does this happen for every HTML file? What happens if you make a new .html file from scratch that contains: <html><head><title>Test</title></head><body><p>Hello</p></body></html> ... ? –  iglvzx Dec 17 '11 at 2:41

1 Answer 1

up vote 2 down vote accepted

In the registry, go to Computer\hkey_class_root\.htm and change the default to htmlfile (and not chrome).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.