Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a way to prevent textmate from auto-typing a ; after every : when editing CSS? I still want it to auto add closing brackets and curly braces. Just not semi-colons.

I've seen the option in the prefs but it will only disable all closing characters.

share|improve this question
    
Are you editing a CSS, or in which case does this happen? Have you looked into the options? – Tom Wijsman Dec 17 '11 at 2:26
    
yes with css. I've seen the option in the prefs but it will only disable all closing characters. – Christian Schlensker Dec 17 '11 at 2:27

Other than asking the developers to consider implementing an option for that I don't really see a way in which this could be achieved, there are two ways to handle this by yourself:

  1. Consider switching to another editor or even IDE, that's built more towards CSS.

  2. Get used to the flow of the automatic generation of :; constructs, it was added with a reason.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .