Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My boot times became a bit too much so i decided to take a look ad kernel log to see what might be causing the problem..

There i noticed repeating:

12/17/11 02:25:28 PM    EXT4-fs (sda6)  re-mounted. Opts: data=writeback,errors=remount-ro,commit=60,commit=600
12/17/11 02:25:29 PM    EXT4-fs (sda7)  re-mounted. Opts: data=writeback,errors=remount-ro,commit=60,commit=600
12/17/11 02:25:29 PM    EXT4-fs (sda2)  re-mounted. Opts: data=writeback,errors=remount-ro,commit=60,commit=600

New messages of this kind continue to appear after the system is up and running, which is strange as i got all the filesystems mounted.

How to stop the remount attempts?

Some info.

My fstab:

#sda6
UUID=20fee089-ad39-4264-91f0-39aad7c84809 /               ext4    defaults,data=writeback,errors=remount-ro,commit=60,noatime 0       1
#sda7
UUID=b58528df-37fd-46c8-8160-d7dc0efc78cd /home           ext4    defaults,data=writeback,errors=remount-ro,commit=60,noatime 0       1
#sda2
UUID=ee463441-e841-40ab-b255-f14db4077b61 /media/stuff    ext4    defaults,data=writeback,errors=remount-ro,commit=60,noatime 0       1 

I'm on kubuntu oneiric, Linux 3.1.4-030104-generic x86_64 kernel.

Any help would be appreciated.

EDIT:

ok i found out on ask ubuntu that it's because of going to and from battery power. Since my power socket is a bit loose, the switching happens all the time unless i have my laptop put on something stable like a desk.

So my new question is: How do i disable this funcionality? I don't care if the disk has to spin up more often.

share|improve this question
    
Did you run fsck ? –  Maxime R. Dec 17 '11 at 17:37
    
@Maxime see my edit. –  soulcheck Dec 17 '11 at 17:48
    
Ok, does my answer work for you ? –  Maxime R. Dec 17 '11 at 18:56
add comment

1 Answer

up vote 1 down vote accepted

The behavior you want to disable is controlled by the following script :
/usr/lib/pm-utils/power.d/journal-commit

As said on the Ubuntu help site :

to disable a script from /usr/lib/pm-utils/power.d/ simply create an empty file in /etc/pm/power.d/ with the same name and without the execute bit set.

So, let's just do that :

sudo touch /etc/pm/power.d/journal-commit
share|improve this answer
    
i must've missed that when i read that page and i thought it can be only customized, but not turned off. stupid me. thanks. –  soulcheck Dec 17 '11 at 19:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.