Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A friend just bought a new computer running Vista Home Premium 64-bit. I installed MSN Explorer which he used before for email and web browsing.

He wants to set his default email program to be MSN Explorer so that if he tries to send email from other applications like Picasa, MSN will pop-up. Unfortunately I am unable to set his default email program.

If I go to Control Panel > Default Programs > Set Default Programs, MSN is not listed. It also isn't listed under Set Associations when trying to associate the MAILTO: link.

I then went into MSN Explorer, then to Settings & Help > Email Settings and clicked to make MSN Explorer the default email program. A pop-up dialog comes up stating "MSN Mail is now your default email program." But MSN is still not listed in Picasa as the default email program. MSN Explorer is version 9.60.0053.2200 and is the Verizon co-branded version.

Any idea how to make MSN the default email program?

share|improve this question
add comment

2 Answers 2

MSN Explorer has fallen out of the circuit many years ago. What I suspect your friend is trying to do is to set his/her Hotmail account to be the default email.

To achieve that - I strongly recommend you use Windows Live Mail instead of MSN Explorer (which hardly anyone uses nowadays!).

When you install Windows Live Mail, it makes it really easy to get your Hotmail on your desktop, and also it will allow you to set it as a default email client.

Strongly recommended - get off Microsoft's excuse of a crapware called MSN Explorer.

share|improve this answer
add comment

Sort of agree with scoopdreams about using Windows Live Mail, however I disagree calling MSN Explorer "crapware" it was nice in its time (far from perfect). For computer illiterate friends, it was a nice program to do your email's in.

Anyway, I am not sure exactly with your problem as I did not know it was available on Windows Vista, however maybe you should try right clicking on the icon and clicking "Run as Administrator" then try setting it as default.

It really should not be a problem as UAC is meant to provide system wide changes and not user level changes, but, you never know!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.