Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

ASUS laptop and Xubuntu (11.10) running off the live CD will give me my dual monitors, but when I install Xubuntu I can't set up dual monitors. When I boot from the live CD both monitors come on even before it is fully booted. But in installed mode "desktop" and "grandr" says only one monitor. The "NVIDIA X Settings" show two monitors, (CRT-0- (ViewSonic VX1937), and DFP-0- (Apple Color LCD)), but the CRT-0- has no information in its window and the "Reset Hardware Defaults" button is grayed out.

share|improve this question
    
did you try to run the display monitor utility as sudo –  LowvaPrg Dec 28 '11 at 18:29
    
What video card are you using? Is it with NVidia Optimus? –  kobaltz Dec 28 '11 at 19:48

1 Answer 1

Looks like this is a known issue. This is what I found on the Ubuntu Forums. Hope it helps you.

Re: 11.10 dual monitor nvidia card problem

Hi folks! I guess I've found a solution for the multiple displays problem... only thanks to you guys.

1.) disable active drivers (if you have any after fresh install f.e.)

2.) install nvidia drivers current (not pre-release)

3.) reboot

4.) type cd /etc/X11/ and then cp xorg.conf xorg.conf.backup (it makes copy of your configuration file... {just in case})

5.) open up the terminal and enter: sudo apt-get install gtk2-engines-pixbuf

6.) after installation enter sudo nvidia-settings (it opens up the Nvidia X Server settings)

7.) goto X Server Display Configuration

8.) set your settings, BUT! don't hit apply... when you are finished hit Save to X Configuration File

9.) log off and log in again

and voala it should be done now! I had problems saving my X configuration file but I fixed it by the step number 4

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.