Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
OS X: using the keyboard to select an option in a message window / box?

On Snow Leopard 10.6 I used to be able to use tab and space to navigate between buttons and select one. I looked through the Accessibility preference pane and I have the "enable access for assistive devices" enabled, and everything else looks good - it is factory default.

Two examples of dialogs I can no longer navigate with tab / space:

textmate dialog

photoshop dialog

share|improve this question

marked as duplicate by Daniel Beck, techie007, 8088, ChrisF, studiohack Jan 8 '12 at 0:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Don't know about the setting in Lion, but for these dialogues, pressing Cmd-D results in Don't Save. –  slhck Dec 19 '11 at 7:32
    
-1 This question does not show any research effort. I generally like your questions and enjoy answering them, but this one could have been solved with half a minute of research. –  Daniel Beck Dec 19 '11 at 18:27
    
@DanielBeck Un -1'd. This is still a common problem other people might search for. –  Lri Dec 19 '11 at 20:43
1  
@Lri Sure if you think the question is worth it. I'd go with the top hit when searching for "osx dialog keyboard" on the site instead. –  Daniel Beck Dec 19 '11 at 20:46
1  
Holy huge shadows Batman! –  techie007 Dec 19 '11 at 21:35
show 2 more comments

1 Answer

up vote 7 down vote accepted

The ability to Tab through all controls is not and has never been controlled by the “Enable access for assistive devices” setting (which is for enabling third-party software only).

It is controlled through the setting System Preferences → Keyboard → Keyboard Shortcuts → Full Keyboard Access:

“Full Keyboard Access: In windows and dialogs, press Tab to move keyboard focus between: • Text boxes and lists only • All controls   Press Control+F7 to change this setting.”

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.