Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recieved a computer with Intel motherboard chipset DH67CL and on board GPU DT GT2. I have connected a DVI monitor (Acer AL1721 or iiyama prolite e481s). I have installed Windows 7 64 bit (Enterprise) and everything was fine but the resolution (800x600). I have changed the resolution on windows to 1280x1024 but the resolution on the display didn't change and it automatically switched back to 800x600. Then I have tried a lower one 1024x768. This worked better then 800x600 so it is still in this resolution. I also have realised that windows recongizes my DVI connected monitor as "Generic PnP Monitor ın Standard VGA Graphics Adapter"

My most important problem is, that after Windows Update "Intel Corporation - Display - Intel(R) HD Graphics Family" (Published 12/7/2011) I can't see the Login screen in windows. After the update it requires a reboot. After the reboot I can see the Windows Logo with "Starting Windows..." text. But then instead of jumping into the login screen "No signal" appears on my monitor (with both monitors mentioned above). So I reboot windows in secure mode and restore system before the update and everything works fine.

I have tried different resolutions, newest drivers of Intel but no chance... And I really can't figure it out how to show Windows that it is NOT a VGA adapter BUT a DVI?

Edit 1: Actually I have downloaded the drivers from Intel's website... I got the computer from university and I can't reach anyone, who built it. I have found the chipset and GPU model numbers with AIDA64. But still have this problem... I also have switched in BIOS under "Primary Video Adapter" from "Auto" to "Int Graphics (IGD)" (There were also "Ext PCIe Graphics (PEG)", "Ext PCI Graphics" and "Manual"). And under "IGD Primary Video Port" from "Auto" to "DVI-I (Blue) Digital". Still no signal in login screen.

Edit 2: Display adapter shown in "Device Manager" is "Standard VGA Graphics Adapter" and the associated driver is: Driver Provider: Microsoft Driver Date: 6/21/2006 Driver Version: 6.1.7600.16385 Digital Signer: Microsoft Windows

And "the device is working properly."

Edit 3: Other driver versions... Intel(R) 82579V Gigabit Network Connection: 11.13.51.0 Intel(R) Display Audio: 6.14.0.3074 Realtek High Definition Audio: 6.0.1.6482 Most of all others are also Microsoft 6.1.7600.16385

share|improve this question

2 Answers 2

Most all of the video cards are capable of operating in "VGA" compatability or safe type modes. so you can always see something. In the bios, and before drivers are installed properly, while installing an OS, using Boot disk without drivers. We could all be very happy that they chose that over a blank screen. Log-in screens can be at full res in win7 , and it seems (I am not sure) that thier resolution setting is somewhat seperate to the desktop res. Remember different users can have different DPI and Reses, so it makes sence.

DVI connected or HDMI or VGA or even analog video connects , a card or Integrated video can still work with this "VGA compatability" thing. VGA compatability mode is not limited to "VGA" even if originally :-) that was one of the few ways of connecting (a Name that stuck). the res your achieving on the desktop is still possible in this "compatability" mode. The hardware connection you have it is still possible to be in VGA compatability.

Thanks to all the clues you provided, the most likely problem you still have is that the proper video drivers are not all installed and operational.

Windows update can get and install drivers for your video device, but in my experience it is not the best place to get them or, rely on them. Others also specifically say to Avoid getting the windows drivers/updates for video cards, because it can be a problem. they turn updates off till they get them installed, that bad :-)

SO, get to the manufactures site for your video device, and research it well and get some good exact correct video drivers for your video device and install them. Avoid Going to BS sites that claim to fix or provide drivers, go direct to the Actual manufacture, do not pass GO, do not pay $200 :-)

While your at it, you should research the motherboard chipset drivers and find a good set of those also (from the manufacture). One you go through that fun adventure, then check in your Device Manager and see what is going on with the video drivers one time.

There are many other switches (like to force vga) settings and problems you could have , hundreds, but I would not even start getting deeper into the possible issues, just yet.

share|improve this answer
    
Thanks a lot for the very nice explanation. Actually I have downloaded the drivers from Intel's website... I got the computer from university and I can't reach anyone, who built it. I have found the chipset and GPU model numbers with AIDA64. But still have this problem... I also have switched in BIOS under "Primary Video Adapter" from "Auto" to "Int Graphics (IGD)" (There were also "Ext PCIe Graphics (PEG)", "Ext PCI Graphics" and "Manual"). And under "IGD Primary Video Port" from "Auto" to "DVI-I (Blue) Digital". Still no signal in login screen. –  Genom Dec 19 '11 at 14:06
    
Get into the "Device manager", what item is shown in "Display adapters", what driver is shown in properties of that item? Please update your question with more info as you get it. –  Psycogeek Dec 19 '11 at 14:27
    
@Genom The more info you provided shows that the video drivers packages are still not installed, or your in a safe mode or MSconfig is set to force vga mode. if you are installing these video drivers and they are not working, you might then try Removing them all first. –  Psycogeek Dec 20 '11 at 0:00
    
I have removed them (except Microsoft's driver) and installed again but no benefit. –  Genom Dec 20 '11 at 11:10
    
(via the web) looks like there is a BIOS memory allocation for the internal graphics communities.intel.com/thread/20695 3rd post. set to maximum? Here is a persons full layout of thier driver numbers and some bios settings for GD model communities.intel.com/thread/26159 Last post –  Psycogeek Dec 21 '11 at 4:25

My supervisor has found the problem... Interestingly new Intel drivers don't support some old DVI monitors. These 2 monitors I have mentioned above are all old monitors. And both of them are not supported and have compatibility problems with the driver. Now I have a new monitor which works perfect!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.