Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with filedisk tool ( on Windows 7.

I am creating FS image with mksparse:

mksparse ramdisk.vfat 4M

Then trying to mount it with filedisk tool:

filedisk /mount 0 ramdisk.vfat R:
R: System cannot find the path specified

However, this is working OK on Win XP. What could be the problem on Win7?

share|improve this question

Try running as administrator... (i.e.

runas /user:administrator "filedisk /mount 0 ramdisk.vfat R:"

) You can use your user account if you're a local administrator just to trigger UAC.

or start the cmd prompt as administrator (right-click run as administrator)

I'm not 100% sure... but seems about right. Basically even when you're an administrative user... you're still not considered an administrator until you get UAC to do it's thing.

share|improve this answer
Thanks, but what if according company policy I don't know the password for administrator, is there some "tick" for account to set this type of permissions? Or any other workaround for my situation? – pmod Dec 20 '11 at 7:17
@pmod: If you don't have admin rights to your workstation, then you won't have access to modify what requires admin rights and what doesn't. There is no workaround unless you acquire admin rights. – surfasb Dec 20 '11 at 10:09
@TheCompWiz Actually "start the cmd prompt as administrator" works for me - (the environment is only different for PATH, and SESSIONNAME appeared, USERNAME is not changed) - the issue is still the same – pmod Dec 20 '11 at 11:57
up vote 0 down vote accepted

My fault: I found out that updating driver and tools from the latest archive ( solves the issue.

Latest news: Allow to mount images without administrative privileges...

share|improve this answer

Its because the driver is not signed as in filedisk.sys. use this program found here

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .