Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using SVN 1.7.2 binaries on my German Windows XP machine. What I need to do to make it output text in English instead of German?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

This should do the trick:

export LANG=C
export LC_MESSAGES=C

It tells svn not to translate any message (english being the default). Alternatively, you can force it to english by using:

export LANG=en_US
export LC_MESSAGES=en_US
share|improve this answer
1  
Mike is using Windows - therefore "export" will not work. Anyway setting LANG=en_US works. –  Robert Dec 19 '11 at 14:56
    
I assumed he used svn under Cygwin, which supports "export". –  Ravachol Dec 19 '11 at 14:57
1  
Setting LC_MESSAGES is not necessary if it was not set already; LANG is enough. –  grawity Dec 19 '11 at 15:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.