Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently formatted a hard drive as ext3 to get it to mount in CentOS 5. Now it automatically mounts when I connect it to the USB port, and mounts to /media/disk, but i am not able to write to it.

here is the output of my mount command:

/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw,acl,usrquota,grpquota)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sdc1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
/dev/mapper/vg_epa1-lv_root on /lv_root type ext4 (rw,acl)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
epa2:/shares/epa2 on /shares/epa2 type nfs (rw,acl,hard,intr,addr=172.31.10.19)
nemo:/shares/nemo on /shares/nemo type nfs (rw,acl,hard,intr,addr=172.31.10.20)
nfsd on /proc/fs/nfsd type nfsd (rw)
/dev/sde1 on /media/disk type ext3 (rw,noexec,nosuid,nodev)

The last one is my external drive. it is showing as rw, so how come I cant put files on it?

share|improve this question
    
What happens when you try to write files to it? What are the permissions on the target drive/folder? –  techie007 Dec 19 '11 at 17:36
    
I can't even make a target folder on the drive. it returns "mkdir: cannot create directory `test': Permission denied". The permissions in /media/disk are drwxr-xr-x 3 root root 4096 Dec 19 11:49 . –  Derek Dec 19 '11 at 17:40
1  
It appears that only "root" has write permissions. Are you the "root" user? Does it work if you change permissions to (say) 777? –  techie007 Dec 19 '11 at 19:52
    
Didnt realize you needed to change permissions to wide open. I was root on both systems, but I formatted on one system, and used it on another –  Derek Dec 19 '11 at 21:49
    
It's not that you NEED to change them to wide-open, I suggested it for the sake of testing/troubleshooting. :) –  techie007 Dec 19 '11 at 21:55
add comment

1 Answer

If you are using kde you probably need to dig into policykit options I think. I had similar problem, and changing permissions with that helped me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.