Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently doubled the amount of RAM in a Windows 7 box and I want to ensure I'm taking full advantage of it. Is there a way to reset SuperFetch?

share|improve this question

migrated from serverfault.com Dec 19 '11 at 22:02

This question came from our site for system and network administrators.

up vote 6 down vote accepted

If you're using an SSD, Superfetch is off by default as it doesn't make sense in an SSD system.

If you're using Server 2008 R2, Superfetch is off by default.

If you're using Windows 7 on a conventional hard drive:

Run "net stop fileinfo", and delete the following three files under... AgGlFaultHistory.db AgGlFgAppHistory.db AgGlGlobalHistory.db (all under C:\Windows\Prefetch)

"SC Start SysMain" will get it going again.

share|improve this answer
    
fwiw - Anyone using Rammap and experiencing c0000417 - An invalid parameter was passed to a C runtime function. on a 64-bit system, resetting Superfetch was what solved that issue. – Lieven Keersmaekers Mar 21 at 6:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.