Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using usb-creator-gtk to create a bootable USB with Ubuntu 11.04. The USB device is a SanDisk Cruzer 4 GB, and I have already used u3-tool to remove the U3 cruft that comes with SanDisk devices, and completely wiped the USB stick.

When I run the command:

 ely@AMDESK:~$ usb-creator-gtk -i /home/ely/Downloads/ubuntu-11.04-desktop-i386.iso

the usual GUI pops up. I select the 4.0 GB USB filesystem and click "create." At this point, a popup window appears that says "Installing" with a progress bar. It steadily moves to the 38% complete mark and then just freezes. If I force-quit the process, re-wipe the USB drive and re-try, I get the exact same error.

Why does usb-creator-gtk just hang with no information? How can I prevent it from freezing so I can finish the bootable drive creation process?

share|improve this question

2 Answers 2

I just googled for a similar problem (stuck at 38%, but different usb drive). Turns out that after leaving it for 10 minutes, it eventually asked for sudo permissions to write the boot loader, and then got stuck at 99% for a long time ("Creating a persistence file").

Eventually it completed, but it took about 30 minutes in all. I have no idea why it takes this long (given it took 5 seconds to copy the iso in the first place) or why they can't create a progress bar that's a little more reliable.

share|improve this answer

This isn't an error. It's at a point where it's writing a very large portion of the installer. It's probably around 500+MB (Unpack the ISO, guarantee there's a big file in there.)

The only way to speed this up is by getting a better USB stick

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.