Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install "mail" on a Red Hat 4.1.2-48 box. I tried:

yum install mail

It prints out:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.anl.gov
 * epel: mirror.steadfast.net
 * extras: centos.mirrors.tds.net
 * ius: mirror.rackspace.com
 * updates: yum.singlehop.com
base                                                     | 1.1 kB     00:00     
epel                                                     | 3.7 kB     00:00     
extras                                                   | 2.1 kB     00:00     
ius                                                      | 2.2 kB     00:00     
updates                                                  | 1.9 kB     00:00     
utterramblings                                           |  951 B     00:00     
Setting up Install Process
No package mail available.
Nothing to do

How can I work around this?

share|improve this question
3  
4.1.2? Really? – Ignacio Vazquez-Abrams Dec 20 '11 at 8:18
    
ok, figured out that I need to do "yum install mailx" instead. But why am I not getting any email still? – teepusink Dec 20 '11 at 8:35

Perhaps you meant yum install mailx?

You can test it sends emails using echo "Test" | mail yourname@domain.tld

share|improve this answer
    
Thanks Vlad, yes I figured that part out as posted in my comment above. But why am I not receiving the email now? What steps am I missing now? Thanks. – teepusink Dec 20 '11 at 8:42
    
What MTA are you using? Sendmail, exim? – Vlad Dec 20 '11 at 8:54
    
It is Sendmail. – teepusink Dec 20 '11 at 9:49
    
Have a look over the configuration sendmail.com/sm/open_source/docs/configuration_readme If everything looks ok, check to see if the messages are bounced by the recipient's server or marked/sent to spam. – Vlad Dec 20 '11 at 11:41
    
its echo "Body" | mailx "subject" yourmailid – user288274 Jan 9 '14 at 9:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .