Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the following scenario:

Windows 7 64-bit, hosting an XP Mode, on the host machine there is Oracle 10g installed. On the XP Mode there is Oracle Client installed.

From XP Mode I am able to connect to Oracle on the host machine using its IP ONLY.

Example:

sqlplus username/password@12.12.12.12

However I need to connect to that Oracle instance using the NAME of the host machine. How do I do that? What settings should I make?

i.e.

sqlplus username/password@HOST_NAME
share|improve this question

You would need some type of local DNS setup to make this work. If the computers join a windows domain and the domain controller is setup as a DNS server ( the normal case ) this would work "out of the box". Your router may have the option for local DNS otherwise you will have to setup your own DNS solution.

share|improve this answer
    
ok, thank you really it puts some light on the ussue. I think the general overview is more complicated - I'm in a VPN. – karla Dec 21 '11 at 8:00
2  
If you only need to resolve the name on the win 7 system and the XP guest IP does not change you could put an entry in the win 7 systems host file. – Lamar B Dec 21 '11 at 8:04
    
That's a lovely idea! I'll try it right away! ...but is it going to have effects when I try to connect from XPMode to the host machine? – karla Dec 21 '11 at 8:25
    
You would have to do the same in reverse for the XP guest – Lamar B Dec 21 '11 at 11:36
    
Windows has included a local name resolution service (NetBIOS) ever since version 3.11. DNS is not required for simple usage (although highly recommended on production environments). – grawity Dec 21 '11 at 12:41
up vote 1 down vote accepted

I got another solution.

I added the couple - ip address, host name in Windows' hosts file, then on I could use the host name.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .