Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a mac mini and a macbook. On the mini runs a apache +php installed via macports. Everything works fine on the local enviroment. But I don't have access to the site with my macbook. When I start the websharing in the system configuration I have access to the personal site. But this is not what I want. Has anybody an idea how I can fix this problem?

share|improve this question
    
I want to connect over the ip of my macmini. It is 192.168.2.111 The error message is Server not found –  jens freudenau Dec 21 '11 at 10:33

2 Answers 2

up vote 1 down vote accepted

I've never run Apache on a Mac, but you may need to tell Apache to listen on your IP address as it may be listening on the loopback. You will need to find the config file. On Linux it's in /etc/apache/.

You would look for the line that says Listen it needs to read Listen x.x.x.x:80 where x.x.x.x is your machines IP address, or you can use Listen 0.0.0.0:80 to listen on all interfaces on port 80, since your mac seems to have a webserver built in you may need to disable the web server before starting apache OR make apache listen on a different port other than 80.

share|improve this answer
    
that's work, thanks –  jens freudenau Dec 21 '11 at 11:20

I think that you should use hostname.local and not only hostname when you want to access the web site.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.