Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been using imap gmail on my iPhone for about 14 months now, to archive emails I used to just move them to all mail on the phone and they would archive. However recently (since the outage last week I think) moving to 'all mail' has no effect when I look at the mail in the web client (with single and multi threaded emails).

I had orriginally set up the iPhone from the automatic settings, but in looking for a solution to my current problem, I found this article (which actually seems to provide a better way of archiving using delete). However it also doesn't work as expeccted. Now when I select delete, the message is labeled "deleted messages", but it remains in the inbox.

Anyone else having the same problems, or know a reason why I am having these issues?

share|improve this question

2 Answers 2

I just checked, moving the mail to the "All mail" folder still works for me.

I had originally set up the iPhone from the automatic setup too.

share|improve this answer
1  
Thanks Olivier, really strange, I cannot think what might have changed on mine. Are you on firmware 3.0 or greater? –  Richbits Sep 10 '09 at 7:24
    
Yes, firmware 3.0 Did you try to delete the settings and recreate it? –  Olivier Payen Sep 10 '09 at 14:36
    
Yes, I had it automatically set up, then used the article to reset it all. I also get some other strange behaviour which may or may not be iPhone related - A lot of my messages get marked as read before I have read them. However I have just deleted again and set up using the automatic set-up and it seems to be working, except that I cannot change the delete action to not put stuff in the "bin" but apply a label.... And now it isn't working again atall, think I'll see if I can get anything out of the gmail forums. –  Richbits Sep 11 '09 at 15:14
    
I just tried this, and it works fine. Latest iPhone OS (3.1.2). –  Jonik Oct 23 '09 at 12:35

In GMail Mails are only labelled "deleted" (and not moved to some trash). If the Mail-Client on the phone does not know which of the IMAP-folders the "trash" is (meaning: do not show things labelled as "deleted"), it will show mails in the inbox.

Check this setting on the iPhone: In your Settings > Mail > GMail go to Advanced and assign deleted items to the according IMAP-folder in GMail.

share|improve this answer
    
Sorry I don't understand what you are saying here. In Gmail web client the delete button sends the message to a Bin label and archives it, it does not just label it as deleted or binned. Setting up according to the article is as far as I understand supposed to set up a label "Deleted Messages" (Which it did) and when deleting on the iPhone should assign to the label and Archive. It is the archive that is not happening when I delete, or when I move message to All Mail. –  Richbits Sep 7 '09 at 14:36
    
The imap folder which is used for delete is entitled "Deleted Messages" and this is what is being assigned to messages when I select delete on the iPhone. –  Richbits Sep 7 '09 at 14:38
    
Have you at least tried to follow about what I would check on the iPhone? I'm running a different language, so my wording might be wrong. But that worked for me, so "deleted" messages are labelled "Deleted Messages" and archived (meaning they will not show up in the Inbox anymore). –  Wolf Sep 7 '09 at 19:10
    
Yes, the deleted messages folder is an imap folder created by gmail when the account was set up on the iPhone. As a test I have tried changing to another folder, and in both cases the label gets added, but the mail is not archived. –  Richbits Sep 10 '09 at 7:29
    
I just had time and played a little around: And finally could recreate your problem. For me it helped to call up the web interface of Gmail, change to "Settings" and "Label" and delete the offending label "Deleted Messages" once. Since then, it has not come up - although I have deleted and archived messages again and again. Maybe this helps? –  Wolf Oct 6 '09 at 15:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.