Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Followup question for my previous one:

So I have a directory \etc\install\foo that allows file sharing.

I have a file NEW.zip from an unshared location that I moved into \etc\install\foo, and therefore NEW.zip does not inherit permissions from \etc\install\foo.

Is there an easy way to reset the permissions for NEW.zip so that it does inherit permissions from its containing directory \etc\install\foo ?

(without manually trying to match permissions, which is a pain, and without copying the file, which is problematic for very large files, hence the whole reason it was moved and not copied to its present location)

share|improve this question

1 Answer 1

up vote 3 down vote accepted
  1. Open the file's Properties - Security tab and click on Advanced

  2. Look for a checkbox "Inherit from parent the permission entries..."

  3. If "Inherit" is already enabled, disable it and choose Remove when prompted.

  4. Remove all permission entries from the list.

  5. Enable "Inherit" again.

  6. Click OK to close both windows.

If the current ACL disallows further ACL modifications, you can override it by taking ownership of the file. (The owner can always modify ACLs.) If Windows doesn't prompt you automatically, you can take ownership from Advanced - Owner; you must be an administrator to do so.

share|improve this answer
    
sweet! I found the Properties - Security - Advanced tab myself, but had no idea what to do with it. Thanks! –  Jason S Dec 21 '11 at 22:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.