Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with Windows 7 not sleeping.

PowerCfg -requests

says a "Legacy Kernel Caller" driver prevents the sleep mode. This is not very helpful or informative. How do I get more details about that object?


I found that

Powercfg -requestsoverride 

is the best way of dealing with such misbehaving drivers and software.

The option -requestsoverride is not very well documented. MSDN doesn't mention NAME is case sensitive, and to remove a request from overrides list you give the option with blank REQUEST parameter.

share|improve this question
I added another suggest: powercfg -request – surfasb Dec 22 '11 at 5:58
That's the command I used initially :) – majocha Dec 22 '11 at 9:19
up vote 8 down vote accepted

Thanks for all the suggestions!

Finally I narrowed down the problem simply by trial and error, disabling devices and rebooting. It was a TV card driver hung and not releasing the power request despite being no longer in use.


Unfortunately, the problem with TV card is intermittently recurring. Googling shows it's also quite common. I found that disallowing the driver from making power requests with

Powercfg -requestsoverride Driver "Legacy Kernel Caller" System

solves it.

"Legacy Kernel Caller" is translated on different Windows language versions. On my Polish system it says "Starszego typu obiekt wywołujący jądro".

share|improve this answer
Thanks for adding the English translation - solved my issue too. – Praesagus Apr 30 '13 at 15:26
When I run powercfg -requestsoverride Driver "Legacy Kernel Caller" System, where it succeeds, and then powercfg -requests, it still shows [DRIVER] Legacy Kernel Caller under SYSTEM: in the list of things preventing the computer from sleeping. So it doesn't work. – Neil Nov 28 '15 at 2:01
For me it worked, in terms of removing the entry. (Turned out that HipChat prevented sleep mode and not the PERFBOOST entry.) – Simon A. Eugster Mar 2 at 14:01

This is not really an answer but rather a further question to the OP (since I seem to be unable to comment on the question asked by the OP).

After you used Powercfg -requestsoverride Driver "Legacy Kernel Caller" System, did its entry in the Powercfg -requests list disappear? Because I have the exact same problem you described but unfortunately your solution didn't help me.

I now have the [DRIVER] Legacy Kernel Caller in both my -requestsoverride and my -requests list but the PC won't go to sleep at all (I double checked for case sensitivity, all the Windows Sleep settings and there are no other things listed in the -requests list)

share|improve this answer
I have the exact same symptoms. – Neil Nov 28 '15 at 2:03

From the start menu, type in "Performance Information and Tools".

Click the Advanced Tools and click generate a System Health Report. It should point out legacy driver issues.


Also try powercfg -request.

share|improve this answer
Unfortunately, the report was not helpful, there are no device problems indicated. – majocha Dec 22 '11 at 2:03
about par, 50,000 pieces of info and the one piece of info you need you cant get. That is probably why I would look through the device list and GUESS and temporarily disable. I tried a powercfg -devicequery all_devices_verbose and get too much info, but it would be hard to weed through it all. Pour it into a spreadsheet, or search for an exact flag, but what is the flag? – Psycogeek Dec 22 '11 at 2:36
@Psycogeek: That's the wrong command to run. Try powercg -requests. That just shows the drivers that are keeping the system from sleeping. – surfasb Dec 22 '11 at 5:41
yes "requests" not "request" ? (not understanding that) . I was trying to find a way for the OP to discover possible items using the full list, which shows every devices power items. But is so thick with data it would take more info or more time to find one that might cause the error they got. – Psycogeek Dec 22 '11 at 8:40

In my case it was Spotfiy that misbehaved. People are going ballistic in their forums over this bug.

Solution: Quit spotify before putting computer to sleep/hibernate

I still question why on earth Windows allow a poorly programmed piece of software to override all power plan settings and create wake timers. Microsoft should take their share of the blame here.

edit: Seems like issue is closed 3 days ago so I guess we should expect a fix soon.

share|improve this answer

Did you install Windows 7 on a machine that was meant for a different OS? Ie, did you download/install Windows 7 drivers for your computer. I've seen this issue with other computers that were a bit dated back. Some had Win7 drivers available but the others were SoL. Also, check firmware updates on your BIOS/Motherboard as it could be an ACPI issue.

share|improve this answer
Ask questions in the comments section of the initial question. – Neil Nov 28 '15 at 2:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .