Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Gnome 3 on Ubuntu 11.10.

In the file manager, when I click a drive under 'Devices', Gnome 3 always pops up a dialog with the choices 'open with files' and 'eject' and then I need to click 'open with files' to get rid of that dialog.

Is there a way to configure Gnome 3 not to do that? I am in file manager already, clicking a drive should show the content in the right pane. Why does it still ask me to 'open with files'?

share|improve this question

You have to disable prompt/start programs when media is inserted. Go to:

Activities > Applications > System Settings > Details > Removable Media

and check:

Never prompt or start programs on media insertion
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .