Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Mathematica's light grid server installed on my computer, but I cannot share the computer so that it can be accessed from anywhere on the network. I tried typing localhost:3737 in my browser, but the page isn't loading.

What must I change/set to see computer on the network.

share|improve this question
    
It may be a windows networking / firewall issue. I tried it once in a mixed windows / apple home network and, if I recall correctly, I had success talking to the mac and to one of the PC's but not to the other. Never got it to work. Home networks with various windows versions are a pain, network-wise. What kind of network do you have? –  Sjoerd C. de Vries Dec 21 '11 at 15:24
4  
This question may draw some close votes because it's a borderline programming / networking case, the latter being off-topic here. We're working on a StackExchange site dedicated to Mathematica. Your question would certainly be on-topic there. Unfortunately we're currently in the commitment phase and questions can't be posted yet. You might consider looking around there (area51.stackexchange.com/proposals/37304/…) and if you like it commit. –  Sjoerd C. de Vries Dec 21 '11 at 15:31
add comment

migrated from stackoverflow.com Dec 22 '11 at 7:54

This question came from our site for professional and enthusiast programmers.

2 Answers

Network access might be blocked by a software (or hardware) firewall. See if you can "ping" the server from another computer on the network and vice versa. Check your firewall rules to permit Mathematica to receive incoming connections (on both computers). Can you give any details about your network?

share|improve this answer
    
actually I turned off the firewalls, problem is that I can see just one computer on the network, but I forgot what I already changed. And on that computer I can see in browser it (localhost:3737) –  Pipe Dec 21 '11 at 16:04
    
localhost will evaluate to the computer you are working on for each computer you are on. You need to verify that you can reach each computer from the other. Have you tried to ping? –  Eli Lansey Dec 21 '11 at 16:25
    
I didnt try ping. How to do that? Problem is that can not see the computer on the network, and something I must set in Mathematica or in Grid Mathematica to enable shearing –  Pipe Dec 21 '11 at 17:44
    
Are you running Windows? Do you know how to open a command prompt? Do you know the IP addresses of the various computers? If Windows, [Start]-[Run]. Type in: cmd. At the prompt type ping hostname or ping IPADDRESS –  Eli Lansey Dec 21 '11 at 19:35
    
It was not the problem. I solved it. The problem was after installing the grid, you must make the registration to allow computer to be visible for shearing. Thanks anyway –  Pipe Dec 22 '11 at 17:20
add comment

Here is very wild guess:

Perhaps,

Edit->Preferences->Parallel Lightweight Grid tab

helps?

share|improve this answer
    
It is not the problem to find Lightweight Grid tab in Mathematica. It is in Evaluation, but what I must to do as I can see the my computer on the internet. localhost:3737 doesn't work –  Pipe Dec 21 '11 at 13:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.