Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm building a new Windows 7 machine and trying to add an old NTFS SATA disk as a secondary drive to the system, but having problems.

The system is a new Core i3 on a Z68 motherboard, the OS is Windows 7 Home Premium installed on a OCZ Agility 3 SSD and the hard drive is a Samsung HD501LJ. I installed Windows on the SSD without the HD installed.

After installing the hard drive, I boot windows and go to Disk Management and it says

You must initialize a disk before Logical Disk Manager can access it.

In addition, the Disk Management console is showing the size of the drive as 931.52GB, rather than the 465.76GB that the bios and other machines, show.

Since I initially put it on a SATA III port, I tried moving it to a SATA II port, but that made no difference. I then tried putting it into an external SATA enclosure, and while it then showed the correct size and didn't ask me to initialise the disk, it didn't allow me to access the drive either. It correctly showed that it was Basic disk and contained a Healthy, Active, Primary Partition, but it didn't show the volume name, allow me to set a drive letter or acknowledge that it was an NTFS volume.

The hard drive works fine on my Vista and XP systems. Ideas appreciated.

share|improve this question
    
I have this exact same problem, right down to the presence of the SSD, the incorrect size being reported and the error in disk management. Internal HDD is not recognised by Windows on my new PC. In the end I gave up - a friend now has those hard disks. –  Justin May 14 '12 at 9:00
add comment

2 Answers 2

Try booting from a Linux Live CD such as Ubuntu

If Linux sees the HDD properly, then the problem is likely a missing Windows driver.

On the other hand, if Linux acts similar to Windows with regards to this HDD, then it is likely a hardware issue.

share|improve this answer
add comment
up vote 0 down vote accepted

It appears that this was Windows 7 getting confused.

When I first tried to install Windows 7, setup detected the HD as device 0 and the SSD as device 1 and both drives were reported as the correct size. I partitioned the SSD in setup and afterwards, the SSD was showing as device 0, and the hard drive was showing as device 1 with an incorrect size. This seems to be where W7 corrupted it's idea of what size the hard disk was.

In the end, the way I got the system to recognise the hard drive correctly was to wipe the SSD and reinstall Windows 7 from scratch.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.