Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
 unixodbc-2.3.1-1-i686   196.1K  209.8K/s 00:00:01 [######################] 100%
 apr-util-1.3.12-4-i686  164.0K  201.4K/s 00:00:01 [######################] 100%
 firefox-9.0.1-1-i686     12.1M  215.4K/s 00:00:57 [######################] 100%
 git-1.7.8.1-1-i686        2.3M  216.7K/s 00:00:11 [######################] 100%
 qt-4.8.0-2-i686          20.4M  211.5K/s 00:01:39 [######################] 100%
 gperf-3.0.4-4-i686       88.5K  155.0K/s 00:00:01 [######################] 100%
 qtwebkit-2.2.0-3-i686     6.5M  257.3K/s 00:00:26 [######################] 100%
 kdelibs-4.7.4-2-i686     11.4M  262.4K/s 00:00:44 [######################] 100%
 redland-1:1.0.15-2...   185.9K  168.1K/s 00:00:01 [######################] 100%
 libreoffice-common...    55.4M  259.2K/s 00:03:39 [######################] 100%
 libreoffice-base-3...  1691.9K  257.5K/s 00:00:07 [######################] 100%
 libreoffice-calc-3...     3.9M  231.9K/s 00:00:17 [######################] 100%
 libreoffice-draw-3...     3.4K 1205.4K/s 00:00:00 [######################] 100%
 libreoffice-extens...    27.7K  134.0K/s 00:00:00 [######################] 100%
 libreoffice-extens...   104.5K  183.0K/s 00:00:01 [######################] 100%
 libreoffice-extens...     2.1M  249.1K/s 00:00:09 [######################] 100%
 libreoffice-extens...     7.4K  457.5K/s 00:00:00 [######################] 100%
 libreoffice-extens...    78.3K  162.8K/s 00:00:00 [######################] 100%
 libreoffice-extens...    29.3K  138.2K/s 00:00:00 [######################] 100%
 libreoffice-extens...     8.0K   38.7M/s 00:00:00 [######################] 100%
 libreoffice-extens...   370.6K  194.7K/s 00:00:02 [######################] 100%
 libreoffice-extens...   181.4K  205.6K/s 00:00:01 [######################] 100%
 libreoffice-extens...   287.7K  227.0K/s 00:00:01 [######################] 100%
 libreoffice-extens...     2.1M  259.0K/s 00:00:08 [######################] 100%
 libreoffice-extens...    84.1K  168.9K/s 00:00:00 [######################] 100%
 libreoffice-extens...   656.9K  245.6K/s 00:00:03 [######################] 100%
 libreoffice-extens...    77.5K  166.3K/s 00:00:00 [######################] 100%
 libreoffice-extens...    42.3K  100.3K/s 00:00:00 [######################] 100%
 libreoffice-extens...    36.2K  165.0K/s 00:00:00 [######################] 100%
 libreoffice-extens...    51.2K  130.4K/s 00:00:00 [######################] 100%
 libreoffice-extens...   596.7K  228.5K/s 00:00:03 [######################] 100%
 libreoffice-gnome-...   172.9K  198.0K/s 00:00:01 [######################] 100%
 libreoffice-impres...    98.2K  167.1K/s 00:00:01 [######################] 100%
 libreoffice-kde4-3...    47.6K  126.3K/s 00:00:00 [######################] 100%
 libreoffice-math-3...   270.1K  225.4K/s 00:00:01 [######################] 100%
 libreoffice-sdk-3....     4.7M  253.9K/s 00:00:19 [######################] 100%
 libreoffice-sdk-do...   737.7K  248.9K/s 00:00:03 [######################] 100%
 libreoffice-writer...     2.3M  259.4K/s 00:00:09 [######################] 100%
 pyqt-4.8.6-2-i686         2.2M  219.2K/s 00:00:10 [######################] 100%
 python2-pyqt-4.8.6...     2.0M  255.7K/s 00:00:08 [######################] 100%
 redland-storage-vi...    16.1K   82.1K/s 00:00:00 [######################] 100%
:: Retrieving packages from community...
 wine-1.3.35-3-i686       14.4M  247.8K/s 00:01:00 [######################] 100%
(89/89) checking package integrity                 [######################] 100%
(89/89) checking for file conflicts                [######################] 100%
error: failed to commit transaction (conflicting files)
filesystem: /etc/mtab exists in filesystem
Errors occurred, no packages were upgraded.

error: failed to commit transaction (conflicting files) filesystem: /etc/mtab exists in filesystem Errors occurred, no packages were upgraded.

Any idea why am I getting this error?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

The Arch Linux website has a news item explaining this:

News: filesystem upgrade - manual intervention required

2011-12-20 - Tom Gundersen

When upgrading to filesystem-2011.12 there will be a conflict with /etc/mtab.

Install the package as follows:

pacman -S filesystem --force

It is strongly advised to avoid the --force or -f switch as it is not safe. However, in this particular case it is needed as deleting /etc/mtab manually would break pacman.

The reason for the conflict is that the file used to be generated at boot and hence not owned by any package. Now it is a symlink to /proc/self/mounts owned by filesystem. This change means that initscripts no longer requires write access to the rootfs (though other packages might).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.