Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I mean the pages that appears after any addon updates itself and normally is shown only once next time Firefox restart , like these

but for me it is happening after each restart.(Win 7 and everything is updated )

I was waiting for Firefox 9 to remove this error that i had from 8. but after today's update to version 9 this problem is still with me

share|improve this question
    
i shift + run it in safe mode and reset every setting and controls but not yet fixed – imanabidi Dec 26 '11 at 15:32
    
i also upgraded to beta 10.1 today and still not fixed – imanabidi Dec 26 '11 at 15:32
1  
Your Firefox profile is corrupt, or there is a conflict with your extensions or plugins. Try Firefox Portable to see if the problem persists. – iglvzx Dec 27 '11 at 0:03
    
thanks, but instead of running a clean portable version which will work i would rather go with a new profile and sync it and install my addons again. but i hoped that with some magic or resetting something it will get fixed – imanabidi Dec 27 '11 at 11:39
    
@iglvzx i installed portable and synced it correctly but i wish i have my normal Firefox back. – imanabidi Jan 1 '12 at 6:27

@FlashGot:

what's the value of flashgot.firstRunRedirection in about:config? If true, toggle it to false, restart Firefox and see what happens.

@FireShot:

Check the same with fireshot.firstTimeRunFlag.

share|improve this answer
    
thanks,these 2 was corrected. but 1 remaining problem is although extensions.foxyproxy.firstrun is false(as you said) its startup page is shown after every restart – imanabidi Dec 28 '11 at 5:06
    
+ mozilla.org/en-US/firefox/10.0/whatsnew is opened after every restart + firefox checks for addons update during startup although i checked every checkbox for update option to false – imanabidi Dec 28 '11 at 5:11
    
even if i toggle extensions.foxyproxy.firstrun to true and restart it will switch to false after restart as expected, but successive restart is showing firstrun page again, very weird – imanabidi Dec 28 '11 at 5:15
    
my startup.homepage_override_url setting is mozilla.com/%LOCALE%/%APP%/%VERSION%/whatsnew and i couldn't find any setting to turn this of.by the way my homepage is empty. – imanabidi Dec 28 '11 at 5:18
    
i removed and reinstalled the foxyproxy but the problem is not solved – imanabidi Dec 28 '11 at 5:24
up vote 1 down vote accepted

Finally I created a new clean profile as @iglvzx said.

only type firefox.exe -p in Windows 7 and you will find out the rest.

  • the nice thing is the default profile is still there in case you want to switch back to it or to copy important files from old profile

  • although i have already synced Firefox i then Recovered important data from an old profile (like Form History, ..)

  • finally i went to add-ons panel and clicked Install Add-on from file.. command and then multiselect all my previous *.xpi files

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .