Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Well as the title says, I'd like to know how I can save the value of my overscan compensation (value is between 0 and 200) after reboot on Ubuntu 11.10. The graphics card I have is an Nvidia ION. I'd really like it so that it works without me having to do anything once I've set it. It's always needing the overscan value 100, so would like to have it as that. I've tried this fix to no avail. Any help would be appreciated!

Additional information: The setting for the compensation value is found under GPU-0 - (ION) tree item in the x server settings, and appears to be separate from the x Screen setting

share|improve this question
    
Just by the way, why aren't you looking for an answer that works? –  wizlog Jan 2 '12 at 3:24
    
@wizlog - Not sure what you mean. I AM looking for an answer that works. Unfortunately I'm at a loss since nobody seems to know the answer to how to save these settings correctly –  Jay Gilford Jan 2 '12 at 13:03
    
When you used "this fix" did you add/change any other lines of code? –  wizlog Jan 2 '12 at 15:14
    
Are you changing the overscan value to be used with a TV, if so, please provide a link to manufacture's website, or a model number. –  wizlog Jan 2 '12 at 15:16
    
The model is the Nvidia Ion 2 - The Tv is a Goodmans, although it's not possible to do the compensation via the TV (I've tried everything). The nvidia compensation works, its just that I have to change the setting every time I boot the computer manually, and don't want to have to do this –  Jay Gilford Jan 2 '12 at 17:28

2 Answers 2

Add nvidia-settings -l (this is a l as in load-settings, not an I as in Intention) to your desktop autostart. Read your desktop-environment / window-manager manual in order to find out where your autostart is.

-This worked 100% for IndyUK who seems to have had the exact same problem.
Ubuntuforums also has a similar question, which was solved the same way mentioned above.

share|improve this answer
    
That only enables or disables overscan being possible from the looks of it. I want to be able to set the value of the overscan compenasation. This has had no effect on the actual overscan compensation value –  Jay Gilford Jan 2 '12 at 17:18
    
Once overscan "becomes possible", what is its default value? –  wizlog Jan 2 '12 at 19:16
    
Have you tried it? If it works, you can simply have it start each time Ubuntu boots. –  wizlog Jan 2 '12 at 20:48
    
I have overscan showing in the nvidia configuration anyway, that's not an issue. The problem is getting the overscan compensation to save. I tried the above yes and it didn't fix anything –  Jay Gilford Jan 2 '12 at 20:57
    
Look at my answer again, I changed it. –  wizlog Jan 2 '12 at 22:19
up vote 1 down vote accepted

The issue here appeared to be the Nvidia save settings was writing and adding my screen name in front of the settings when saved. I ran the command that wizlog suggested nvidia-settings -l from the command line and got an output similar to this. I've then gone about finding out why the errors were occuring, and found out that simply changing all of the hostname:0.0 to simply 0 fixed this

Big thanks to wizlog for his persistence in this, and although didn't give the answer, certainly provided a basis for me to figure it out!

share|improve this answer
    
Big thanks to @Jay Gilford for the 100 rep! –  wizlog Jan 2 '12 at 23:26
    
You're welcome! –  Jay Gilford Jan 2 '12 at 23:28
1  
I hope you've had a pleasant experience on Super User. Please don't hesitate to come back when you need help, or when you want to help others. –  wizlog Jan 2 '12 at 23:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.