Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up a home network with a new wireless router (LG-ERICSSON WBR-3020). I am using WPA2-PSK encryption with AES. When I enter the passphrase on my macbook air (OSX 10.7.2) it connects flawlessly when given the passphrase, and similarly with an iPad, and iPod touch. On my Windows Vista laptop, when I give the correct passphrase it has "limited or no connectivity." This computer uses an Atheros AR5007EG Wireless Network Adaptor. In the wireless connection properties, all the boxes are checked, including IPv4, IPv6, and Client for Microsoft Networks. (Unchecking IPv6 as some people have suggested does not help). IPv4 is set to obtain an IP address and DNS server automatically.

share|improve this question

migrated from serverfault.com Dec 22 '11 at 22:45

This question came from our site for professional system and network administrators.

    
Have you connected to a WPA2-protected network before on this Windows computer? –  music2myear Dec 22 '11 at 22:52

2 Answers 2

When I've had trouble like this it normally means the wireless network driver does not support that particular form of network encryption.

You can test this by setting your security to WPA(1) and seeing if the Windows computer connects OK to that.

Also, I'd try disabling any special utilities managing your network, none of them do any more than Windows does, and none of them does it as easily either.

share|improve this answer

Can you ping computers on your network? If you can't, or the adapter shows 0 packets sent, try downloading the latest drivers for your wireless adapter. After Windows XP, Windows got proficient at connecting to wireless networks out of the box, but in rare cases some adapters aren't fully supported by Windows.

Edit: If that doesn't work, @music2myear is probably right: your adapter doesn't support WPA2 encryption.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.