Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wanted to use OpenCL under Windows 7. I've got everything set up (Cuda Toolkit 4), the nvidia card is compatible (GeForce 310M).

I've got a Acer Travelmate 8372 with optimus, and I've got a bios option where I can choose between Switchable and Discrete or something similar. But if I choose the discrete option, all of the rendering is done over the intel chip, it's not even listing the nvidia card in the device manager anymore.

In switchable mode I can not find an option to enable the nvidia card explicitely. Hence the CUDA OpenCL Platform is not available.

Also I'm a bit confused about driver versions. Acer provides a Version 8.16.11.8997 (from 2011/11/24), where as NVidia provides the latest driver version 285.62 (from 2011/10/24). Why do these versions differ? Because of Optimus?

I can't install any of the drivers provided by nvidia, the setup is complaining about incompatible hardware.

Edit: As I read optimus itself cannot be disabled, because the Intel chip is the graphics gateway either way. so the question should be: how can I install the Nvidia development driver on my optimus systen?

share|improve this question
    
At least you're not trying to run linux. Optimus is like leprosy in linux. –  kobaltz Dec 23 '11 at 3:46
    
Well actually the Bios switch is working as desired under Linux... It uses the Nvidia card explicitly. –  rdoubleui Dec 23 '11 at 7:33
    
And I was able to install the Nvidia development driver on Linux. –  rdoubleui Dec 23 '11 at 7:37
    
Yea. My laptop didnt have the toggle in the BIOS. Had to use Bumblebee. –  kobaltz Dec 23 '11 at 12:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.