Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 Pro, 32-bit... when I go into Component Services and expand computers and right-click on My Computer and choose properties, the Options tab has a disabled Enable partitions option that I have not been able to figure out how to enable. Windows 7 'help' indicates that it can be available (by virtue of not saying anything to the contrary), nor can I found any security/group policy setting to enable/disable this.

The only thing I've found on Microsoft's site about documents it as not being available only for WinXP and Win2000 (again suggesting that Win7 should be good).

Any thoughts or ideas? It's always possible that it's not available on Windows 7, but I've not even found anything that confirms this either.

(might be worth noting that this same question's been asked over in stackoverflow a few months ago by a different user, but has attracted little activity. I'm thinking this community may be a better forum for this query).

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I've found a possible answer; according to: http://social.technet.microsoft.com/Forums/windows/en-US/a601d45a-10c0-4da9-a424-d35afef22161/how-to-enable-windows-7-windows-8-com-partitions-function

I'll quote in it's entirity:

According to the Product team on this behavior, starting from Windows Vista, they have the “Enable Partitions” checkbox grayed out on client desktops. This was an intentional change as they want the ability to have COM+ partitions to be available only on servers and not client desktops.

...which makes me wonder why the blazes the checkbox is there in the first place if there's never going to be a way to enabled it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.