Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I set up a web server in my Windows 7 with easyPHP. The website works fine when you browse to http://localhost/ or http://127.0.0.1/. But, you can't open the site from another computer in my LAN. My local IP is in the 10.x.x.x range. I can ping other machines on the same LAN. But, I cannot browse to 10.x.x.x from my own or any other PC.

I am currently easyPHP on Windows 7 with the firewall turned off on my private network.

P.S.: I fixed one problem: In httpd.conf I changed Listen 127.0.0.1:80 to Listen 80. Now browsing the page using localhost works fine, but using 10.x.x.x I get an Access forbidden message.

share|improve this question
up vote 4 down vote accepted

The problem has been fixed:

The problem was in httpd.conf:

1) I did change my Alias

<Directory "C:/Users/...">
Options FollowSymLinks Indexes
AllowOverride None
Order deny,allow
</Directory>

2) Listen key from Listen 127.0.0.1:80 to Listen 80

share|improve this answer
    
If this solves the problem, please click on the ✓ symbol to accept this as the answer. – user33758 Dec 25 '11 at 3:29
    
After searching all over google the point 2 from your answer solved it. – Iulian Onofrei Jun 24 '14 at 8:28

Changing the Listen port to 80 in the http.conf file allowed me to access my computer as a web server from another computer. The default file displayed was in my "EasyPHP/www" folder. When I moved content thier, it was displayed.

When I updated the "Directory" section of the of the http.conf file (along with the Listen port change) I was able to see other directories I specified there.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .