Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Pre problem: My system crashed recently while I was in XP. I booted into DOS and ran ScanDisk to check my XP partition (FAT32) and ran a surface scan. Once I was satisfied that the system drive was clean and intact, I tried booting into XP. Unfortunately, it didn’t (quite) work.

Problem: When I try to boot XP, it seems to do nothing, though I can see the HD LED continually flicker now and then. The screen is black and there is a Windows 2000-esque text-mode/ASCII-art progress bar at the bottom of the screen which very slowly inches forward.

Observation: If I try to boot in safe-mode, it looks like nothing is happening for a bit, but then I see the drivers being loaded like normal, except that each one is loaded slowly (~3-5 seconds per file). For each one, aside from the time it takes to load it, I can hear the hard-drive briefly griding (one or two short bursts of noise and HD LED flashes).


Test 1: I rebooted into Windows 7 (on a different drive) and mounted each of the registry hives and exported them to .REG files. I then repeated it with a very recent copy of the hives and compared them. The files are nearly identical (other than the changes that have been made in the two days between the backup and the crash). Therefore, the registry should be okay.

Test 2: I then copied the entire XP drive to an archive, then expanded that to another drive and compared that to the original XP drive. The whole process went without pause, took just a few minutes and worked without error (ie, no hard-drive read issues). I used an imaging tool to clone the drive and verify it, again without any problems.

Test 3: I was watching a movie, so I decided to let it sit there as long as it needs. It turns out yes, it does boot. First I booted in safe-mode and after several minutes, once it finished loading gap440.sys, the hard-drive light went solid and Windows loaded and ran as expected. I then rebooted in normal mode and the text-mode progress bar slowly inched forward. After 11 minutes of that, the HD LED went solid and Windows loaded and ran as expected (though it loaded with a new, blank profile instead of mine; I have to edit the profile directory in the registry to set it to the correct one). I repeated the normal boot and it once again took 11 minutes before the XP splash screen was shown.


Question: So what could be the problem? Why would XP be loading the drivers so slowly?

share|improve this question
1  
Does it ever fully load Windows XP in any mode? –  CharlieRB Dec 23 '11 at 19:02
    
Yup; it can load just fine once it gets past the excruciatingly slow driver loading. –  Synetech Dec 23 '11 at 19:40
    
I would read the smart data on the hard drive, sounds like the drive is running in pio mode. –  Moab Dec 23 '11 at 20:44
    
@Moab it runs fine after it finishes the driver-loading phase (and used to run fine before the crash). Would it actually reset somehow? Even if it were running in PIO mode, it shouldn’t behave like this because when you first install Windows, it runs in PIO mode since it does not have drivers installed yet, and that does not run like this. –  Synetech Dec 23 '11 at 21:05
    
So are you going to show everyone what's in your boot log, like the other people reporting this problem did? ☺ –  JdeBP Dec 23 '11 at 21:39

1 Answer 1

up vote 1 down vote accepted

Good news and bad news.

The good news is that XP is running fine again. The bad news is that there is no rational explanation for the fix. (Sadly, even though computers are supposedly deterministic machines, they often exhibit intermittent or even “random” behavior.)

In any case I used the behavior I was observing to try something. The disk is properly readable and the files are all present and intact. I have a fresh backup from today, so I figured that I would format the drive (scanning for bad sectors, of which none were found), and restore the drive.


There were at least three ways to restore the drive. (1) Use the cloning tool to restore the drive image, (2) Mount the image and copy all the files to the drive, or (3) Extract the files from the archive to the drive.

Cloning the drive would restore the drive to (presumably) exactly the state it was in before (which would be pointless since it wasn’t working in that state). Copying the files and folders would cause all of the folders to lose their original timestamps (not a huge deal, but I for one do not like that). So I extracted all the files from the archive to the freshly-formatted drive.

I rebooted into DOS and ran a ScanDisk and surface scan. Both good. I ran Western Digital’s DataLifeGuard (Quick and Extended tests). Both good. I rebooted and selected XP from the boot menu. Two seconds later the XP splash screen came up. I then got the Improper Shutdown dialog (because the registry is from before I did the 11-minute-boot tests), so I entered a note about that. A few seconds later, I was booted into XP and things seem to be running smoothly (that’s where I am typing this from right now).


The problem is fixed, but I don’t know what it was. Considering the solution (wiping the drive and copying the files back), my best guess is that it was a bad write to one of the file-system structures—one that could not be detected by ScanDisk, chkdsk, Norton Disk Doctor, etc. (No, it was not a virus; the crash was because of a power failure while the system was running.)

share|improve this answer
    
WTF? Someone down-voted the solution to my problem and didn’t even bother to leave a comment as to why? That’s audacious and arrogant. I experienced a problem that nobody could help fix. I figured out a way to fix it, and posted it so that others can know what to do if they experience the same problem. Where does somebody get off down-voting a solution that worked (and not even give a reason for what their problem is)? This reeks of unrelated revenge-voting which demonstrates the problem with the SE system. –  Synetech Dec 31 '11 at 20:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.