Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running Windows XP SP3 on a laptop, when the system reboots, it can't connect the wireless, or even show wireless networks in range.

On a Lenovo or IBM ThinkPad T42, the Fn+F5 key enables or disables the wireless. Whenever I tried pressing it, a message comes up saying:

Unable to change the power state of the 802.11 wireless radio. Please update the driver

Fine, I updated the driver. Same thing happens.

Turns out there are a lot of issues relating to that message. Of the solutions I've seen, none have worked.

One thing that started to get it to work was to uninstall the Lenovo software. The last thing that did work was to do a netsh winsock reset and reboot. So I put that into a script for the customer, and told her if it buggers up again, run the script. Having said that, I don't have the laptop here any more.

Whenever the system reboots, it will not connect to the wireless, or show wireless networks in range. When it reboots, it gets an APIPA (Automatic Private IP Addressing). I click Repair, and it stops at Renewing IP Address.

Why is this happening? And what would be the cause?

On a Windows XP SP3, and all the updates were done while wired up. Power saving settings for the network card are set to never shut the card off.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.