Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm without a hard drive for the moment, and would like to install some mods on minecraft inside of my Ubuntu live usb. Unfortunately I can't find the files once minecraft has installed (and works).

Are the files (the .minecraft folder) hidden away in the RAM like I suspect? Can I access them somehow? DDD for GDB was suggested, is this the right way to go?

Thanks.

share|improve this question

migrated from stackoverflow.com Dec 24 '11 at 8:31

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 2 down vote accepted

cnicutar is right, there's no reason to try for gdb or ddd. Neat tools, overpowered for this task.

strace(1) is also pretty neat and a bit more appropriate, but I think there's an easier way: find where writable content can actually be written.

Chances are good the output of mount or cat /proc/mounts or cat /proc/self/mounts will show you a mounted filesystem that is writable. Start looking there. Try find /path/to/writable/mount -iname '*minecraft*' -print if you're confident that the files will be named with a minecraft in them. (-iname for case-insensitive matching.) If minecraft files have a common extension, you could search for that instead.

share|improve this answer
    
Thanks! I got a lot of weird entries with cat cat /proc/self/mounts but find /path/to/writable/mount -iname '*minecraft*' -print worked really well when I used it with root '/'. I found out that the folder I was looking for was simply hidden... thanks for the help! –  Yamist Dec 24 '11 at 9:36

I don't think GDB and DDD will be of much use. I would use strace and pour over the output to see what the process open(2)s.

For instance it often happens that I run something that's so poorly documented I can't find the list of files it tries to read on startup. It's just easier to strace and see it for myself.

share|improve this answer
    
Thanks, strace seems really useful, although I wasn't able to get it working with this problem I'll keep it in mind next time I need to debug something without sourcecode. –  Yamist Dec 24 '11 at 9:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.