Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Can't figure this one out. I've set up FTP with a filezilla server on my windows 7 machine at home. If I'm within the local network and connect with the LAN 192.168.x.x IP address, it succeeds, but if I attempt to connect to the WAN ip with the port forwarded it fails.

I thought my ISP might be blocking port 21 so this is all done with a random port I chose (port 10622). The port is reported as open by

Things I've tried on the windows 7 machine:

  • Disabling firewall at the domain, home and public levels
  • Added additional rules allowing port 10622 to ingoing and outgoing (just in case)
  • Checked all settings for "exclude this IP" related settings (there are none)

I have RDP working correctly remotely with the port forwarded, so I don't think it's an issue with my router (which is a dd-wrt flashed cisco router). I am also successfully forwarding another random port for torrents.

Any suggestions are appreciated, thanks!

share|improve this question
The ftp server is set in Active or passive mode ? – aleroot Dec 24 '11 at 11:10
Passive, although I've tried both. – John Dec 24 '11 at 11:13
netstat -na, pls. And check port-forward rules with any smart TCP-listener – Lazy Badger Dec 25 '11 at 4:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.