Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've tested xmonad on ubuntu and archlinux, running either on virtualbox and vmware. After installing guest additions (and the equivalent vmware tools for vmware), the focus border stops working. I was just wondering if there was a workaround or if anyone has a similar setup working?

share|improve this question
    
What are the guest-addition-tools? Is it a package that I did not find in my search for it? –  Robert Massaioli Dec 25 '11 at 12:47
    
@Robert Massaioli yes it's a package that allows your guests to go fullscreen, share the mouse and clipboard with the host, and to use the Shared folders, virtualbox.org/manual/ch04.html –  bneil Dec 25 '11 at 13:50
    
You're not alone in the world: I have exactly the same problem :-( –  Nicolas Wu Mar 5 '12 at 15:43
    
@NicholasWu If you're using osx as your host machine, you can use parallels which doesnt have the same issue. –  bneil Mar 6 '12 at 18:48
    
add comment

1 Answer

up vote 4 down vote accepted

After some research, I found that these steps resolved the issues for me.

sudo apt-get install xcompmgr

Then just run the following in a terminal (or whatever) that should be kept alive for the rest of your session:

xcompmgr

I just discovered this when blindly trying stuff from various blogs and the VirtualBox ticket. I'm having an OS X host and Ubuntu 12.04 64-bit guest.

share|improve this answer
    
Yes, a thousand times. This worked for me :) –  mjg123 Oct 14 '12 at 20:53
    
Thank you! I had rendering problems and artefacts, relating to window borders, running awesome wm under VMware, and xcompmgr solved everything. –  thnee Jan 19 at 13:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.