Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had a working Win 7 64-bit machine. I purchased a Razer Black Widow Ultimate Stealth keyboard. I confirmed that this keyboard has the latest firmware and works by using it on another Windows 7 64-bit computer, first try, no problems.

But on my computer I installed the Razer software and it said there was no keyboard detected. Since then I have had increasing problems with my USB devices.

My Microsoft Ergonomic Keyboard 4000 stopped working. It cannot install the proper diver. Code 28. Even though I didn't uninstall any drivers.

Then Bamboo (CTH-460) stopped working. Code 28. I can't fix the driver.

Now I can't even hook up a standard USB 2.0 hub. Even it shows up as Unknown Device.

I have tried using the device manager to uninstall and reinstall the drivers. I have even tried this in safe mode.

All these devices continue to function properly if I connect them to my other Win7 64-bit box 3 feet away from this one.

I have run out of ideas.

Anybody seen this happen before? Did some root driver get screwed up that is breaking everything down stream from that driver?

update: So far no progress in determining the problem. And it is now at the point that if I take a functioning USB device, say my mouse, unplug it and plug it back in a different USB port, it will cease to function and it will be reported as an Unknown Device. Cycling power doesn't help. At this point I am not sure I can spend any more time on this and I may have to just rebuild the machine from scratch. It will take me a man week, or more, to rebuild this, my main computer. Ugh.

Looks like I need to set up a 4TB NAS and some continuous backup software as insurance against this happening again.

update 2: I have yet to solve this problem. I am going to try one last crazy thing. I am going to migrate the box P2V and then migrate it back V2P. Maybe, just maybe, it might shake it free. Fingers and toes crossed.

share|improve this question
    
Any chance you still have an issue with this...? :) – Coldblackice Jul 9 '13 at 5:39
    
@Coldblackice I am no longer having this issue. I don't remember exactly how I fixed things. Probably by uninstalling the Razor software & then rebooting. But I'm not positive. I do continue to have problems on that computer w/ the Razor software. For some reason I can't update the keyboard firmware on that computer. The flash is emptied & then the bootloader isn't detected to reload the new firmware. I've to take the keyboard to a different computer that also has the Razor software on it & use that computer to update the firmware. Once the firmware is fixed, I can then use the keyboard. – tinjaw Nov 22 '13 at 15:38

Yes, I've seen that before, but it's usually on XP. :)

Perhaps try reinstalling your motherboard chip-set drivers.

Additionally, if you suspect a faulty driver then I would advise using Windows 7's System Restore to go back to a point in time when it was working.

If that doesn't help, then I'd start considering USB power loads (current per Root hub), and/or possible hardware damage.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .