Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just created a wifi network using an 802.11g Airport Express.

My 2010 Mac mini (running Windows 7 via Boot Camp), and my iPhone 4 (running iOS 5) both see and connect to the Airport Express's network just fine.

But my 2009 MacBook Pro (running OSX Lion 10.7.2) doesn't seem able to even see the network.

It has seen the network a couple of times since I set it up (about an hour ago), but when I tried to connect to the network, it rejected the (WPA2 Personal) password (which I checked was correct via "Show password") with a "Connection timeout" error after only about 3 seconds.

I've tried to join the network manually using the "Join Other Network" option, but it can't find the network then either. I've turned wifi off and on on the MacBook Pro, and restarted both the MacBook Pro and the Airport Express.

I must be doing something wrong, but I can't figure what it is.

share|improve this question
Wondering if trashing preferences might be an idea. Not sure which preferences to try. – Paul D. Waite Dec 24 '11 at 21:25
Possibly related thread on Apple support: – Paul D. Waite Dec 24 '11 at 21:46
up vote 2 down vote accepted

Unbelievably, here are the steps that worked:

  1. In System Preferences > Network, I deleted the "Wi-Fi" entry from the list of network interfaces on the left-hand side of the window.
  2. I then re-added it.
  3. I then selected "Join Other Network" in the "Network Name" drop-down, and entered the Network Name and WPA2 Personal password of the network.

Now the MacBook Pro seems to be happily connected to the 802.11g network, just like the iPhone and the Windows 7 Mac mini.

(I had previously trashed and NetworkInterfaces.plist in /Library/Preferences/SystemConfiguration/ and restarted the machine. No idea if that had any bearing on things, but I still had the problem until I went through the steps above.)

share|improve this answer
This worked for me too with Medialink router and WPA2 personal setting. So weird. – zengr Mar 3 '12 at 18:46

I just updated my 2010 MacBook Pro to Lion and then I had the same problem: I couldn't find my airport express. It drove me nuts! And I couldn't even find it with the Airport Utilty.

It turns out that Apple has made a new AirportUtility (5.6) for OS 10.7. But even though I tried to use it, I still couldn't connect to my Airport Express. After trying so many things, here is what worked: from an older Mac I connected to the Express via AirportUtility. I then changed the channel (in manual set-up -> wireless) from "automatic" to "channel 1". And then I was again able to see and connect to my Airport!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .