Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using the default configuration for proftpd on Linux Mint with only the following directive changed:

# Use this to jail all users in their homes 
DefaultRoot         ~

I created a user userftp with the home directory as /home/userftp. Next, I mounted an NTFS partition to /home/userftp/files.

I was able to ftp on to the home directory, but I cannot access the files directory. on the server the permissions shown for the files directory are '700'.

On running ls -l inside /home/userftp, I get the following:

drwx------ 1 wretrovian wretrovian 4096 2011-12-25 16:49 files

I assume the problem is that the owner of the files directory should be userftp and not wretrovian. However, running sudo chmod 777 -R files and sudo chown -R userftp files have no effect on the directory, the output still remains:

drwx------ 1 wretrovian wretrovian 4096 2011-12-25 16:49 files

I suppose I wont be able to apply those permissions to an NTFS system, but is their a way I can change the owner of the files directory? Or any other alternative would also be welcome..

share|improve this question

You should mount the NTFS partition with the option uid=. So something like this:

mount -o uid=userftp /dev/<NTFS-partition> /home/userftp/files.

See section Mount options for NTFS of the mount manpage: http://linux.die.net/man/8/mount

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .