Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I seem to have all the dependencies to install a program, but I'm getting these error messages.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  rabbitvcs-nautilus3: Depends: nautilus (>= 1:3~) but 1:2.30.1-0ubuntu1.2 is to be installed
                       Depends: python-nautilus (>= 1.0~) but 0.6.1-1 is to be installed
                       Depends: python-gobject (>= 2.28.2~) but 2.21.1-0ubuntu3 is to be installed
E: Broken packages

What does that mean? How can I get this installed?

share|improve this question
Are you using a package manager? – soandos Dec 25 '11 at 8:03
Can you edit and include a cat /etc/sources.list /etc/sources.list.d/*.list – Paul Dec 25 '11 at 8:37
@Paul /etc/apt/sources.list and /etc/apt/sources.list.d/* but for Maverick and above these should be in default repository list. to be exact – Karlson Dec 26 '11 at 4:00
@Karlson what they should be and what they are are separate matters – Paul Dec 26 '11 at 12:33
up vote 1 down vote accepted

This error means that in the versions of packages from the current cache for nautilus, python-nautilus, and python-gobject are not at the appropriate versions to install the rabbitvcs-nautilus3. The versions needed are indicated in ().

So before doing anything you should do:

sudo apt-get update

If the error continues then you should add the sources containing the newer versions of these packages to the sources list.

The locations are:


Normally the location for this package would be the same as the package you are trying to install.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .